1. Welcome to Mu-43.com—a friendly Micro 4/3 camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Error message with adapter and lens

Discussion in 'Adapted Lenses' started by ddb, Jul 17, 2010.

  1. Just got a beautiful Minolta MC Tele Rokkor-X QD 135mm f3.5 and a Minolta MD MC to m4/3 adapter. Every time that I attach this combo to the G1 I get a message on the LCD saying "please check that the lens is attached correctly"
    Any ideas on why this is happening?
     
  2. dwig

    dwig Mu-43 Top Veteran

    714
    Jun 26, 2010
    Key West FL
    By default, Panasonic models "protect" the user from failing to get proper pictures due to an improperly mounted lens. Its a nice feature, but prevents using lenses that don't have electronic coupling.

    To use adapted lenses, other than 4/3rds lenses, you must dig into the Setup menu to find the option "Shoot without lens". Change this setting from the default "no" to "yes". The camera will now shoot fine with any lens.
     
  3. Thanks alot. I was really hoping for this to work.
     
  4. grebeman

    grebeman Mu-43 All-Pro

    Mar 13, 2010
    South Brent, south Devon (UK)
    Barrie
    You're not alone ddb, this question has come up several times before, and no doubt will come up again, then it will be your turn to offer advice :smile:

    Barrie
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.