1. Reminder: Please use our affiliate links for holiday shopping!

EPL2 refusing firmware update - Any help?

Discussion in 'Olympus Cameras' started by Bhupinder2002, May 27, 2012.

  1. Bhupinder2002

    Bhupinder2002 Mu-43 Hall of Famer

    Hi Guys
    My EPL2 is playing up and refusing to update firm ware and I have no idea what to do . I have installed new Olympus camera firmware updater but I get the same messege - No camera connected . I have no clue what to do . If anyone has any ideas , please let me know.
    Cheers
    Bhupinder
     
  2. Declan97

    Declan97 Mu-43 Veteran

    379
    Feb 3, 2012
    Padang, Indonesia
    I just updated my e3 firmware through the internet (downloading the firmware), I supposed it should work with others olympus series.

    Are you sure the latest firmware and your epl2 connected to pc/laptop and you click the right process?:)

    Goodluck

    Sent from my 2.3.3|GT-P1000 using EP-L2
     
  3. RT_Panther

    RT_Panther Mu-43 Legend

    May 4, 2011
    Texas
    Did you plug your camera in first before starting up any Olympus programs?
     
    • Like Like x 1
  4. Bhupinder2002

    Bhupinder2002 Mu-43 Hall of Famer

    I dot think so , I started the updater first.Let me see again
    Thanks
    Cheers
    Bhupinder
     
  5. Declan97

    Declan97 Mu-43 Veteran

    379
    Feb 3, 2012
    Padang, Indonesia
    What version of firmware bhu?

    Sent from my GT-I9100 using Evolt 3|PL 2
     
  6. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Did you select Storage on the camera before starting the updater?
     
  7. MajorMagee

    MajorMagee Mu-43 All-Pro

    Feb 24, 2011
    Dayton, OH
    I had one computer where this would happen, and it probably had something to do with the USB drivers. Switching to another computer resolved it.
     
  8. Bhupinder2002

    Bhupinder2002 Mu-43 Hall of Famer

    Hi Guys ..I was connecting camera before running the software . Its all done . Thanks a lot for help.
    Cheers
    Bhupinder