1. Reminder: Please use our affiliate links for holiday shopping!

EPL1 firmware update problem

Discussion in 'Olympus Cameras' started by superstitious, Jan 10, 2011.

  1. superstitious

    superstitious New to Mu-43

    9
    Jan 2, 2011
    First off, I am not sure if this is where I should be posting this, if not I apologize. Anyway, I just purchased the Olympus Pen EPL1 today and have been trying to update the firmware. I downloaded the firmware updater and installed it. I am able to connect the camera using the storage mode. Then once it tried to connect to the server, it failed every time. It kept saying "failed to communicate with the server". I tried doing it with lens, without lens, and removed the updater and reinstalled 3 times and it still wouldn't work. Then I resorted to just install the ib software and tried to update from there but again I had to use the updater and it just kept saying it can't connect to the server. I disconnected and reconnected my internet and restarted the computer many times but it still doesn't work. I have no idea what is left to do. Please help! Thanks so much.

    Kanya
     
  2. shoturtle

    shoturtle  

    823
    Oct 15, 2010
    Mac or PC, the software had problems with mac. Go to this link and get just the updater without all the other editing software. I had a similar problem, and contacted oly tech support about the issue with mac. The simple updater seems to work better for just firmware update.

    OLYMPUS Digital Camera Updater
     
  3. superstitious

    superstitious New to Mu-43

    9
    Jan 2, 2011
    Nevermind, the Oly server itself appears to be down yesterday. I thought I'd try again today before I call CS and it worked! All is good with the new firmware. On to testing out the new autofocus. Thanks Shoturtle.
     
  4. Grinch

    Grinch Mu-43 Top Veteran

    813
    Jan 9, 2011
    Canada
    So your not the only one...my e-pl1 won't update the firmware says that camera is not attached to computer. Using a Mac and everything else works but will not acknowledge camera when I try to update firmware!?!
     
  5. shoturtle

    shoturtle  

    823
    Oct 15, 2010
    if you are using master it did not work for me, I end up using the stand allow updater on my mac that I linked. Have not had any problems with the updater.
     
  6. Grinch

    Grinch Mu-43 Top Veteran

    813
    Jan 9, 2011
    Canada
    Actually tried with updater first, then with master...same results with both says that camera is not attached to computer. Not sure what to do, I can transfer images so I assume connection is correct, only issue for firmware. Have tried different lenses, still won't acknowledge. Might have to deal with customer service, which always seems to disprove the phrase.
     
  7. shoturtle

    shoturtle  

    823
    Oct 15, 2010
    oly teir 2 was quite helpful and friendly. They were the one that sent me the link. They had me remove all the software and just use the updater by itself. Not a big deal as I never use master as I edit with aperture 3.
     
  8. hannu108

    hannu108 Mu-43 Rookie

    14
    Aug 11, 2011
    Netherlands
    Olympus E-PL1 firmware update solution

    Hi,

    I was struggling to update my E-PL1 for several weeks on my MacBook Pro (running MAC OS 10.6.8.) The update attempts (both using Olympus Camera Updater and Olympus Viewer 2 applications) ended in error message "Updater failed to connect with the server (90)." :frown:

    After having done some research on the Internet I finally cracked it and successfully updated the firmware of my new 14-42mm II (MSC) lens and the body.:smile:

    How I did it:

    - I used Windows XP Pro under WMware Fusion (v. 3.1.3)
    - In Windows I switched Firewall OFF (in Control Panels) and disabled my AVG Protection
    - I connected my MAC directly to the modem (instead through my Ethernet hub)

    Hopefully this helps you.

    Cheers!
     
  9. klrman

    klrman Mu-43 Regular

    91
    Aug 11, 2011
    Did you notice any improvement in your lens after the update?
     
  10. SCT

    SCT Mu-43 Regular

    141
    Mar 8, 2011
    Landover, MD, USA
    I haven't updated my EPL1 either since I got it. I just downloaded the Olympus Updater and it had given me problems recognizing the problem as well. The computer recognizes the camera as a STILL CAMERA. Then, I just started pressing buttons. On the camera, once I connected it to the computer, I selected MTP to see what that does. It started a video edit app that came with my computer that I don't use. I closed it. Unplug and re-plug the camera and then select STORAGE on the camera. Then my computer recognizes it as a storage (like a USB memory stick). Now the updater recognizes the camera :)

    Windows, btw.
     
  11. Pap

    Pap Mu-43 Regular

    81
    Jun 16, 2010
    Fleetwood, PA
    One of the reasons I dislike having to do updating on cameras.
    Pap