1. Reminder: Please use our affiliate links for holiday shopping!

EM5 with external flashes

Discussion in 'Olympus Cameras' started by MattyB, Apr 10, 2014.

  1. MattyB

    MattyB Mu-43 Rookie

    11
    Mar 3, 2014
    Okay I'm probably being very stupid here, I've just recently replaced my G6 with an EM5 and when I went to try out my Yongnuo flashes and triggers (RF600 non ttl trigger, YN560 II canon - manual, YN565 canon TTL) The TTL flash didn't work with TTL on the G6 but the rest fired with out a problem. Now I'm finding I can't even get the manual stuff to trigger. My flash icon in the quick menu is sort of greyed out, opposed to being white with the included Olympus flash. Even an old Sunpack flash with no controls that works on everything isn't firing off with this camera!

    Is there a menu setting I'm missing somewhere or does the EM5 not do manual flashes?

    Thanks :)
     
  2. Wisertime

    Wisertime Mu-43 All-Pro

    Aug 6, 2013
    Philly
    Steve
    Turn off AUTO ISO? It does work. I've had the same thing happen...but might have been the ISO.
     
  3. MattyB

    MattyB Mu-43 Rookie

    11
    Mar 3, 2014
    Just gave that a go and no dice :(
     
  4. SpecFoto

    SpecFoto Mu-43 Veteran

    311
    Aug 28, 2012
    So Cal
    Jim
    The EM5 works (in manual) with non-oly flash, I use 3 different types on mine. However it will not be able to use TTL with any flash other than Oly or Panasonic compatible.

    Verify in the Flash Setup menu or SCP that your flash mode is not set to Flash Off.

    Verify in the Shooting Menu 2 that the RC Mode is set to off.
     
  5. RamblinR

    RamblinR Mu-43 Top Veteran

    545
    Aug 16, 2012
    Sunshine Coast, Qld Australia
    Maria
    Make sure you have the flash setting set to on in the menu. If there was enough light in the room the camera might have thought it didn't need a flash so you need to have this setting on all the time.
     
  6. MattyB

    MattyB Mu-43 Rookie

    11
    Mar 3, 2014
    I've tried all these things and every flash I have except the small Oly included one doesn't work! I did notice though when I put the flash onto the hotshoe when its on, it fires off the flash automatically, without a shutter depression. Could I have a faulty hotshoe??
     
  7. WasOM3user

    WasOM3user Mu-43 Veteran

    458
    Oct 20, 2012
    Lancashire, UK
    Paul
    My EM-5 needed to have the earthing parts at the sides of the hotshoe gently cleaned/scraped before my Nissin flash would work reliably.

    Used a very fine emery (nail file) board cut down to do this.
     
  8. SpecFoto

    SpecFoto Mu-43 Veteran

    311
    Aug 28, 2012
    So Cal
    Jim
    Is it just the flash trigger that will not fire, or did you put the a flash, in manual and not in ttl mode, directly on the hot shoe and still have no luck? (Checking if the trigger might me bad)

    Try resetting the camera back to factory standards.

    Try cleaning the hot shoe, only the larger center pin is used for manual flash or triggers, and make sure the trigger/flash is securely mounted and screwed in tight.

    If still a no go, and If the LM2 flash works, which uses the accessory connector in the back of the flash housing for connecting, but other other flash do not fire off the hot shoe, you might have a faulty top flash shoe or internal connection.
     
  9. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    I would think if you are connecting a Canon compatible TTL flash to the Olympus camera then I would be wanting to isolate the TTL pins as they wouldn't be compatible with the Olympus camera & they line up & will connect. Just using tape would not be reliable but a hot-shoe adapter (with a PC connector) would work. Like this in this thread (although it doesn't suit this guys needs).
     
  10. MattyB

    MattyB Mu-43 Rookie

    11
    Mar 3, 2014
    I've tried with TTL flashes in TTL mode and manual mode, and manual flashes and manual triggers. The only thing I can get to work at all is the LM2 Flash. I guess since it's still under it's 90 day warranty I'll be sending it back :( Is this problem fixable or should I be expecting to get a refund and have to try to source another EM5? (I bought from an ebay store who offer a 90 day warranty and the camera was used when I got it - cheap skate I know!)
     
  11. MattyB

    MattyB Mu-43 Rookie

    11
    Mar 3, 2014
    Update: I've got in contact with the shop and they claimed they've fully tested the camera and it was fine but wouldn't confirm they tested with anything else other than the LM2 so they've agreed to take the camera back and test more. Sent it off today and it should be with them on Wednesday after easter. Fingers crossed for a positive outcome!
     
  12. Hazza

    Hazza Just Clicking

    572
    Aug 10, 2013
    Huddersfield UK
    Harry
    I have the exact same problem with my E-M5. It works fine with the small supplied flash, which uses the connector under the hot shoe, but refuses to fire with any of my other flashes.
    I have a metz dedicated flash which fires fine on my other camera but not on the E-M5. I'm pretty sure that it worked originally but can't be 100% as I don't use flash all that much.

    I will be very interested in the outcome of this, keep us posted.
     
  13. RickinAust

    RickinAust Mu-43 Regular

    119
    Feb 9, 2013
    Australia
    I had an issue with a FL600R on RC with flash not firing. I found that the battery was nearly out of juice (not in the flash the one in the camera) replaced it with a spare full one and it worked fine. I don't suppose that this could be the issue. I was really scratching my head as the camera still worked fine with no flash but the fl600R refused to fire?
     
  14. hookgrip

    hookgrip Mu-43 Regular

    150
    May 21, 2013
    I had the same issue as well. I tried using the manual radio triggers that worked fine on my 5D and D700 on my E-PM2, and none of them would work properly.

    In my case, I could get them to fire intermittently, but not consistently.

    Here's the thread I posted about it a while back, maybe it will be helpful:
    https://www.mu-43.com/showthread.php?t=46850
     
  15. Dusky

    Dusky Mu-43 Regular

    48
    Apr 17, 2014
    Toronto
    Mark
    I just tested my em10 with the yn568 and 565 with the yn622c trigger and it works. The only thing that I cannot do is use the high speed sync even if it is mounted on the camera... I can always see the shutter curtain past 250