EM5: EVF autoswitch issue?

Discussion in 'Olympus Cameras' started by Starred, Apr 18, 2012.

  1. Starred

    Starred Mu-43 Regular

    Aug 7, 2010
    When I turn the EVF autoswitch to on, the EVF is working correctly when I look into it, but when I do not look into the EVF there is no image on the LCD monitor?
    When I set the autoswitch to off the image is correctly shown only on the LCD monitor.
    Which setting should I change to get the autoswitch to work correctly?
  2. thinkcooper

    thinkcooper Mu-43 Veteran

    Oct 29, 2011
    EVF options are here:

    Menu>Detailed Camera Options (the gears icon)>J Built In EVF>EVF Auto Switch>ON

    Once you've selected that option, the rear LCD will display the lens view, and will autoswitch to the EVF when you're looking into it. Alternatively, if you press the small "viewfinder" button to the right of the eyecup, your lens display will be forced to the EVF, and the LCD will display the "info" data including the SCP. Hit the viewfinder button again and the LCD returns to the normal "autoswitch EVF" state. Nice to have the option of using the LCD simply as your info panel or as the live view panel with an autoswitch to EVF.
  3. BarefootPilgrim

    BarefootPilgrim Mu-43 Top Veteran

    Dec 23, 2009
    Westchester, IL
    Real Name:
    Unless you're holding the camera too close to your body. Then the autoswitch sensor will think you're trying to look through the VF and switch the LCD off.

    You'll have to experiment to determine how close to your body to not hold it!
  4. akspaz

    akspaz New to Mu-43

    Jun 9, 2011
    Pasadena CA
    I just got my OM-D today... I quickly unbox the camera and decided to skip reading the manuals ( I just can't wait) since Ive been using EP-2 for quite a while..I thought its quite similar but I was having the same problem auto EVF won't switch back to the screen...but I figure it out very quickly...hehe so here are some picture to explain

    GO to the custom menu ---> the gear looking one ---> built in EVF
    <a href="http://www.flickr.com/photos/78993379@N06/6946327680/" title="P4182632 by trueak, on Flickr">[​IMG]"500" height="375" alt="P4182632"></a>

    Turn on the Auto EVF switch
    <a href="http://www.flickr.com/photos/78993379@N06/6946327804/" title="P4182633 by trueak, on Flickr">[​IMG]"500" height="375" alt="P4182633"></a>

    And click your shutter.. you will see this command panel
    <a href="http://www.flickr.com/photos/78993379@N06/7092397757/" title="P4182634 by trueak, on Flickr">[​IMG]"500" height="375" alt="P4182634"></a>

    ALL you have to do left is the find the lOl button located on the right side (facing the screen) of your EVF on your camera and click it once !

    <a href="http://www.flickr.com/photos/78993379@N06/7092376625/" title="P4182635 by trueak, on Flickr">[​IMG]"363" height="273" alt="P4182635"></a>

    Problem Solved! :wink:
  5. Starred

    Starred Mu-43 Regular

    Aug 7, 2010
    Indeed, problem solved! It was the lOl button.

    Thanks all!