EM1 hotshoe cover...lost yours yet?

Discussion in 'Olympus Cameras' started by Dave in Wales, Nov 15, 2013.

  1. Dave in Wales

    Dave in Wales Mu-43 All-Pro

    Nov 5, 2011
    West Wales
  2. bcaslis

    bcaslis Mu-43 Veteran

    Jul 3, 2011
    Wilsonville, OR, USA
    Real Name:
    Brian Caslis
    Nope not lost mine. No problems with it.
  3. deang001

    deang001 Mu-43 Veteran

    Sep 16, 2013
    Hong Kong
    Real Name:
    I'm glad someone else has noticed this. Was starting to think there was something wrong with mine.

    Haven't lost it but it is forever coming off in by bag. Pretty bad design ... just doesn't slot it tightly enough.

    I've replaced it with a normal one I had lying around as I don't want to loose it just in case I sell the camera. A bit worried what this does to the weather sealing, but seems OK.
  4. hkpzee

    hkpzee Mu-43 All-Pro

    Sep 5, 2011
    Hong Kong
    Real Name:
    Mine stays on pretty securely, but this is a good reminder for me to put it back in the box and replace it with a generic hotshot cover! :tongue:
  5. flash

    flash Mu-43 Hall of Famer

    Apr 29, 2010
    1 hour from Sydney Australia.
    Real Name:
    Mine's in the box as well.
  6. monchan

    monchan Mu-43 Veteran

    Jul 7, 2012
    Tottori City, Japan
    I thought I`d lose mine pretty quickly, but luckily it`s never come off by itself.
  7. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    No effect. The contacts are over-molded with the plastic so there is no moisture path. Most cameras that are weather resistant don't come with these covers. The cover that covers the add-on/EVF port is a different story.
  8. JYPfoto

    JYPfoto Mu-43 Veteran

    Aug 27, 2013
    Didn't lose the hotshoe cover, but did lose the front PC sync cover a while ago. Can't for the life of me remember where it fell off.
  9. asparkes

    asparkes Mu-43 Rookie

    Oct 1, 2012
    Real Name:
    I've picked it up out of the sand a few times, is all.
  10. wjiang

    wjiang Mu-43 Hall of Famer

    Is this the same cover as the E-M5? Mine is nowhere near that loose...
  11. dcisive

    dcisive Mu-43 Veteran

    Feb 19, 2010
    Salt Lake City, Utah
    Real Name:
    Never lost the EM5's and this one hasn't come lose either. I guess I must be doing something right. I don't stuff it in a bag in such a way the top rubs (at least not with the type of bag I'm using with side supports). It's actually pretty tight on the EM1 compared to the EM5 so I'm not the least bit concerned about it.
  12. deang001

    deang001 Mu-43 Veteran

    Sep 16, 2013
    Hong Kong
    Real Name:
    Good to know. Thanks.
  13. Andre

    Andre Mu-43 Rookie

    Oct 29, 2013
    Southern California
    Mine was already coming off on the first day of use, so I taped it down with some gaffer's tape.
  14. beameup

    beameup Mu-43 Regular

    Oct 23, 2013
    The PC Sync cord cover easily falls off.
  15. Mikefellh

    Mikefellh Mu-43 Top Veteran

    Jun 7, 2012
    Toronto, Canada
    It's NOT meant to stay on once you purchased the camera and take it out of the box...it's basically to protect the hotshoe while shipping. It has NOTHING to do with weather sealing...otherwise why did every non-weather sealed camera I ever bought came with one?
  16. bcaslis

    bcaslis Mu-43 Veteran

    Jul 3, 2011
    Wilsonville, OR, USA
    Real Name:
    Brian Caslis
    It definitely doesn't have anything to do with weather sealing. But on the E-M1 it has a downsloping extension on the back. This might help prevent the accessory port cover from coming off, which is required for weather sealing. So I don't see any harm keeping it on when not using the flash.
  17. gs3xr_fun

    gs3xr_fun Mu-43 Regular

    Oct 30, 2013
    Real Name:
    I guess it is one flawed design too since it comes off so easily I don't know where I lost mine.
  18. JimUSNY

    JimUSNY Mu-43 Regular

    Nov 5, 2013
    Mid Hudson Valley NY
    Real Name:
    mine is pretty loose, haven't lost it yet though... I noticed this from day one, lost a few of the regular style ones though off other bodies including the em5, so no sense swapping with one of those for me,

    one other thing I noticed the other day, I forgot to seat my usb rubber cover in correctly before going out on a cold morning, the cold made it bend like a banana and harden up and not be flexible enough to get it to reseal in place, after warming up at home it went back into shape and its in, and I had no problem with it staying in place when out the next cold AM.. so make sure its seated good before going out if its real cold out, dont know if snow getting in there could short something or not but I would think it affects weather sealing.. most people probably dont use the usb much, but I download my files through it