EM-10 mk II and OI.Share very, very flaky

Discussion in 'Olympus Cameras' started by FaradayCage, Nov 3, 2015.

  1. FaradayCage

    FaradayCage Mu-43 Regular

    Apr 22, 2010
    So, do I return this thing or is everyone else having trouble? Is this a flaky wifi set in the camera or is it buggy Olympus firmware?

    I have an original EM-10 that works speedily and reliably with the OI.Share app on iOS devices. Same devices, but with this new EM-10 mk II, the flakiness of the function is bad. The app very often says it can't communicate with the camera after just a few minutes. The lag between, say, the shutter button on the app and the actual shot updating on the app screen is very long, much longer than with the older EM-10. Sometimes it just refuses to work, even though the iOS device clearly shows it is connected to the camera's wifi; you can see the camera's IP address and other info displayed in the wifi settings area of the iOS device.

    I have deleted and reinstalled the EM-10 mk II wifi profile several times on the iOS devices, and reset the wifi settings on the camera as well. In fact, while sitting here typing, the iOS device is 18" away from the camera, was fully connected with OI.Share, and just all of a sudden threw up a warning that it couldn't find a camera. With the same iOS devices and same OI.Share app, the old EM-10 never fails.

    I've had the thing for less than a week, so unless some of you out there can tell me you're having the same flakiness, I'm getting tempted to talk to BH Photo about returning or exchanging it. Is that crazy? Am I missing something? I've even disabled the special quick sleep mode thinking that might be related, but it makes no difference.

    thanks, everyone
  2. pmon

    pmon Mu-43 Regular

    Dec 5, 2013
    Real Name:
    I just tested oi share app with my new m10 mkii and I am not able to report any issue like the one you are describing. Even when the camera display gets black I see no relevant delay in the app and I can action the shutter from the app itself.
    Oi share app I have is version 2.62 on an iPhone 4s
  3. FaradayCage

    FaradayCage Mu-43 Regular

    Apr 22, 2010
    Thanks, I'm trying to see if I'm alone on this issue, and if so it goes back to the retailer as defective
    If anyone else can tell me their experience with OI.Share and EM-10 Mk II please let us know if it's working for you
  4. nzdigital

    nzdigital Mu-43 Regular

    Oct 20, 2010
    New Zealand
    Real Name:
    I'm having the same issues with my E-M5 MkII - although I don't have experience with any other model.

    When I first got the camera I tried out the wifi connection just out of curiosity, and it worked fine.

    But now, a few months later, every time I try to connect to the app on my phone (Samsung S3 with 4.3) I get the same 'can't communicate' message.

    I have also deleted and reinstalled the profile several times.

    So sorry, can't help - except to sympathise and say I have the exact same problem with the E-M5 MkII.
  5. FaradayCage

    FaradayCage Mu-43 Regular

    Apr 22, 2010
    I came *this close* to buying the EM-5 Mk II but now you have a similar problem… How long since the OI.Share app was updated on your Samsung? This is making me wonder if in the course of an update, Olympus has munged up the app somehow for certain models. I really don't want to send the camera back to BH Photo if the same problem will occur because it's software.