EM-1, lost the PC Sync cover, what to do?

Discussion in 'Olympus Cameras' started by JYPfoto, Nov 4, 2013.

  1. JYPfoto

    JYPfoto Mu-43 Veteran

    Aug 27, 2013
    I must've misplaced it somewhere while going out shooting, now the front PC Sync port is exposed. I guess I can just put some tape over it for the time being, but anyone know where I can get a replacement? I tried emailing Olympus without success and my call to them resulted in the rep telling me that I would have to send the camera in for repair under warranty for them to replace the cap and return the camera to me.
  2. Wisertime

    Wisertime Mu-43 All-Pro

    Aug 6, 2013
    Real Name:
  3. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    It's the same cover Nikon used on the FM's, FE's, F3's, etc. FWIW, most of the owners of those cameras lost the covers too without any damage to the connector.
  4. tomO2013

    tomO2013 Mu-43 Top Veteran

    Oct 28, 2013
    I also lost the sync terminal cover for my E-M1.

    I tried ordering from the Olympus US site, but unfortunately they only look to supply to the US market and I am unable to access the 'parts' section of the equivalent Canadian or UK websites (I fly back and forth regularly between both places). My local dealer cannot find the code on his system despite that I've provided him with the product number of Item # VE254700-460

    Have you had any success getting replacement parts quickly? I would be interested in trying generic covers except that the official Olympus one screws in and I would be concerned that it may affect weather sealing??

    Any advice, greatly appreciated.


  5. beameup

    beameup Mu-43 Regular

    Oct 23, 2013
    I picked up a generic PC cover off ebay for a couple of bucks. It screws on and won't come off.
  6. Your Funny Uncle

    Your Funny Uncle Mu-43 Regular

    Dec 12, 2013
    York, UK.
    Real Name:
    Googling shows that this is a very common issue. After losing mine I bought three from this US ebay seller, so that I have a couple of spares to hand.They took a week or so to arrive and screw in fine.