1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

E-PM2 body crack close to screws...

Discussion in 'Olympus Cameras' started by shumer12, Sep 26, 2013.

  1. shumer12

    shumer12 New to Mu-43

    1
    Sep 26, 2013
    Hi everyone, does anybody experienced this issue, cracks close to a body cover screws on E-PM2? It is almost new camera (2 months), never been "abused". It seems to me when I unpacked the camera these cracks weren't there... The only abuse this camera had in the past, it is exposure to temperature +5C

    [​IMG][/url]
    EPM2 crack2 by v.cher, on Flickr[/IMG]
     
  2. Jonathan F/2

    Jonathan F/2 Mu-43 Hall of Famer

    Aug 10, 2011
    Los Angeles, CA
    Man, Olympus QC has some issues. It must be the plastic they use. The structural issues have popped up since the E-PL3 and have also occurred with the E-M5.
     
  3. twokatmew

    twokatmew Mu-43 All-Pro

    Jun 1, 2012
    Lansing, MI, US
    Margaret
    My E-PM2 has a slight crack near one of the screws. It came that way new and hasn't gotten worse.

    Sent from my Nexus 7 using Tapatalk 4
     
  4. gochugogi

    gochugogi Mu-43 Veteran

    It may not be structural. I've had the paint crack and eventually flake on lots of products but the underlying body shell was sound.
     
  5. KBeezie

    KBeezie Mu-43 Top Veteran

    694
    Sep 15, 2012
    Grand Rapids, Mi
    Karl Blessing
    Maybe the coating used for the 'look' and feel of the camera wasn't very sturdy.

    I know some manufactures may use one material for the main frame of the body, but that material as cheap as it may be doesn't look aesthetically pleasing so then they would just coat it with another material, I'm thinking maybe that material if hit just right or not applied correctly will crack and peel much like paint chips.
     
  6. BAXTING

    BAXTING Mu-43 Top Veteran

    806
    Aug 5, 2012
    Los Angeles SFV, CA
    Bradley
    Mine has almost the same cracks, but I never noticed it until now.
     
  7. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    Don't see it on mine (9 months old). I'd complain to Olympus.
     
  8. RnR

    RnR Mu-43 All-Pro

    Sep 25, 2011
    Brisbane, Australia
    Hasse
    Crack on mine too - left strap. Strange thing is that I have never fielded straps at all, so it can't be a stress issue.