E-PM1: Stuck Pixel and Blue Light

Discussion in 'Olympus Cameras' started by marko, Dec 25, 2011.

  1. marko

    marko Mu-43 Rookie

    20
    Dec 10, 2011
    Got my e-pm1 for Christmas. I love it. Been using my panny 20mm and oly 45mm. Very pleased with the results.

    Two questions.

    1. I have a stuck pixel right smack dab in the middle of the LCD. Damn it's driving me crazy. It's so small and I can't see it all the time - but I am considering exchanging it with Amazon. Am I crazy?

    2. Is there any way to disable this laser blue light on the top of the camera?

    -B
     
  2. atomic

    atomic Mu-43 Veteran

    224
    Nov 3, 2011
    1. You're not crazy, and it's worth calling amazon to see what they'll do for you.
    2. Electrical tape.
     
  3. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    1. Setup => Sprockets => Utility => Pixel Mapping
    Although, if you have to do this right after buying the camera, I would exchange it. ;)

    2. Electrical tape.
    Yes, it is overly bright isn't it?
     
  4. marko

    marko Mu-43 Rookie

    20
    Dec 10, 2011
    Ned, I thought the pixel mapping was for a dead or stuck pixel in the sensor.

    This is just a stuck pixel on the LCD, not something registering in my photos.
     
  5. dixeyk

    dixeyk Mu-43 Hall of Famer

    Aug 9, 2010
    brand new camera...I would exchange it. The blue light is a bit bright. Electrical tape isn't a bad idea.
     
  6. marko

    marko Mu-43 Rookie

    20
    Dec 10, 2011
    You all have convinced me to exchange it. Should be easy through amazon.
     
  7. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Ah, I see. :) Yes, I thought you were talking about a pixel on the sensor. Pixel Mapping won't help for the LCD. For that you should definitely exchange the camera. If you have a problem with a liquid crystal, it can spread.