E-PL7: problems when chaning lenses

prophet

Mu-43 Regular
Joined
Aug 10, 2014
Messages
136
I have an E-PL7, with the kit lens and the Oly 40-150. Today, when I changed from one lens to the other, the screen only showed black, like the lens was not recognized. I took the lens off and on again, and it worked. Chaging back to the other lens, and the same problem, only I had to take the lens off and on several times before it worked.
Any idea what the problem might be?
 

lowlight

Mu-43 Regular
Joined
Jun 3, 2014
Messages
99
Location
Norway
are you pushing the lens release button when you are attaching the lens again?

if so the lens may move to far and the connections will not align.
 

MoonMind

Mu-43 Top Veteran
Joined
Oct 25, 2014
Messages
994
Location
Switzerland
Real Name
Matt
Just turn the lens a little, possibly back, maybe a little further - as has been indicated, the contacts may be misaligned. It happens - on some cameras more often than on others (e.g. on the E-M10 more often than on the E-PM1). But as long as there's nothing broken (which would be hard to do anyway), it should be fixable instantly.

M.
 

LILIAKU

New to Mu-43
Joined
Sep 1, 2013
Messages
4
Location
Transylvania
It happened to me too a few times with the kit lens, one time it was very embarrassing while changing from the 45 1.8 to the 14-42 before taking a large group photo and ended up taking the pic with my phone :p, anyway it was funny as everyone was too drunk to care.
Maybe the poor construction and maybe that plastic connector of the back of the lens is to blame.
 

cprevost

Mu-43 Regular
Joined
Oct 31, 2012
Messages
59
This could be caused by dirty contacts on the lens or the camera. Wipe with a clean dry cloth. Also could be caused by the lens not seating all the way. Sometimes if you aren't careful you could have the lens almost all the way seated but not quite.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom