1. Reminder: Please use our affiliate links for holiday shopping!

E-PL5 screen going dark during normal use, camera still functions

Discussion in 'Olympus Cameras' started by robogeek, Oct 15, 2016.

  1. robogeek

    robogeek New to Mu-43

    6
    Aug 19, 2013
    Silicon Valley
    David Herron
    I'm having a curious problem with my E-PL5. I've done a bit of researching and am unsure the cause.

    Earlier today I was trying to take some pictures in my office, holding the camera above a subject. I have an Olympus 14-150mm lens. Repeatedly the screen would go blank while trying to take pictures. The camera still functioned - e.g. a half-press on the shutter caused the beep-beep indicating it had locked focus.

    I tried turning the camera off-on a bunch of times to see if that would change the behavior. Usually it would power up to a blank screen. Sometimes the screen would work for a few moments, and then turn blank.

    One idea that came up in a duck-duck-go search (I don't use Google) is the battery might be dead/old/etc. It's the original battery and IIRC I bought this camera in 2013. I had charged the battery overnight so it would be full. I just used a volt-meter across the - and + terminals indicated on the battery, and it reads 8 volts. I'm a little surprised because that indicates a two-cell pack. In any case 8 volts is a reasonable pack voltage because the cells are probably 3.2 volt nominal, and therefore 4 volts per cell is reasonable for the fully charged state.

    I saw discussion on this forum suggesting a possible issue of the lens being rotated too far. It so happens that I had dismounted the lens previously, then remounted it, and now the camera is functioning normally. I've turned it off-on several times now and the screen came on each time.

    Questions:-
    • How else would I test the battery pack? I know from having built a couple dozen electric bicycles and electric motorcycles and an electric car that just putting a volt-meter over the leads while the pack is at rest doesn't tell anything. You have to check the voltage while it's under load, and see how far the voltage sags. But in this case the battery leads aren't available while the camera is operating.
    • How likely is it this is just mis-mounting the lens? I just checked and there is a tiny amount of play in the lens.
    • In June I had dropped this camera from the top of a filing cabinet onto a concrete floor. The fall damaged the 14-42mm lens that was mounted so that the lens no longer zooms. How likely is it further damage occurred?
     
  2. barry13

    barry13 Super Moderator; Photon Wrangler

    Mar 7, 2014
    Southern California
    Barry
    Hi, a loose lens on the mount could certainly explain it... You could try working the lens and see it the symptoms repeat.
     
  3. HarryS

    HarryS Mu-43 Top Veteran

    919
    Jun 23, 2012
    Midwest, USA
    Well, if the LCD is blank because of a loose lens holding out the lens locking pin, the camera will not focus and shutter can;t trip. It won't fire in manual mode either with a half-seated lens. I just checked my EPL5 to make sure.

    My EPL5 screen did the same thing last year. Either the screen failed, or the connections to it broke. My external electronic view finder worked fine. I chose to have mr EPL5 repaired because I liked the camera and the EPL7 didn't offer anything I liked.
     
    • Informative Informative x 1
  4. robogeek

    robogeek New to Mu-43

    6
    Aug 19, 2013
    Silicon Valley
    David Herron
    I checked it more carefully ... I can have it turned on, screen showing fine, and then torque the lens a bit, and the screen shuts off. Turn the camera off then on, the screen is fine, until the lens is torqued again. Again, while the screen is off the camera will focus and trip the shutter.

    The torquing motion required is to hold the body with right hand, then with left thumb push gently against the side of the lens.

    I've also tried torquing the screen and that causes nothing to happen.

    Now I need to see about a repair shop. Any recommendations?
     
  5. callie

    callie New to Mu-43

    7
    Oct 28, 2016
    Eddie
    Suffered the same problem with my EM10. Resorted to putting my fingernail on the lens release button and letting it slip off so the button popped back out.Since then I have removed the lens ring from the body and refitted it without doing anything! Seems to have solved the problem for now.
    AFAIK the problem is with the spring that holds the button under pressure,it may be too weak and lateral pressure is allowing the button to move in slightly and trigger the microswitch(?) HTH.
     
  6. robogeek

    robogeek New to Mu-43

    6
    Aug 19, 2013
    Silicon Valley
    David Herron
    I found these instructions:- Olympus Pen E-PL7 Lens Assembly Replacement - iFixit

    I'm not sure what I'm supposed to be looking for. I took the bayonet mount off, the inner metal ring off, and things seemed to be in order. The pin is correctly operated by the button. Nothing looked misshapen, etc. And now the problem seems worse after reassembly.
     
  7. callie

    callie New to Mu-43

    7
    Oct 28, 2016
    Eddie
    Just a thought,not suggesting you should try it. I wonder if stretching the spring under the pin would help.Personally I live with it,when it does happen I automatically press and release the button.No need to switch off/remove lens etc.
    Observation:It never happens when the kit lens 14-42 or my M42 and PK adapters are fitted.It only happens when using the adapted four thirds lenses,a Sigma 18-125 and an Olly 40-150.
    This is all on my EM10,the EPL3 is fine.
     
  8. RichardB

    RichardB Snapshooter

    442
    Nov 19, 2012
    Maryland, US
    Richard
    There isn't an electronic viewfinder on the camera, is there? My rear screen goes blank sometimes when my hand's shadow falls across the viewfinder and the camera thinks I'm not looking at the screen.
     
  9. Sejanus.Aelianus

    Sejanus.Aelianus Mu-43 Regular

    94
    Sep 28, 2015
    The E-PL5 doesn't seem to have a circuit for auto switching to attached finders. Certainly my VF1 can only be switched with the finder button.