1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

E-PL2 Flash help

Discussion in 'Olympus Cameras' started by mach330, Apr 6, 2011.

  1. mach330

    mach330 Mu-43 Veteran

    240
    Mar 19, 2011
    The OC
    i apologize for the stupid question. i'm a fairly amateur at this stuff as I just got my epl2 2 weeks ago. i've never had good success yet with using flash. so i abandoned it altogether. It was fine until I got to darker areas where now a lot of my pix have that orange background. when i tried to use flash, everything gets overexposed. i can't figure it out. i tried bouncing the flash up, and it's like i never used it. any help would be appreciated.
     
  2. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
    Which flash? Are you using TTL? A? What camera mode? Any Art Filters on? ISO? On-camera flash or are you trying RC?

    We'd need more to help. With what little info there is, it even sounds like the camera's settings are off. I know with a new camera, we tend to fiddle with settings, so try resetting everything, drop to ISO 200 and shoot one.
     
  3. Hyubie

    Hyubie Unique like everyone else

    Oct 15, 2010
    Massachusetts
    Herbert
    I think mach is using the built-in flash. I've been through that stage in the not-so-distant past, and I can tell you there are 2 things you can do: (1) if, like me, you do not like the colors if you use flash, get a faster lens, and ditch using the flash altogether. I rarely use my flash anymore after getting some good lenses; and (2) use some sort of a flash diffuser, even for the pop-up lens that's built-in to the E-PL2. I have used white cardboard, an old film canister (the hard plastic white stuff when you buy film), a cheap flash diffuser/bouncer from ebay. Anything that reduces the harsh light is better than nothing at all.

    And another thing (at least for me): sometimes, a harsh-lighted picture is better than no picture at all. :)
     
  4. mach330

    mach330 Mu-43 Veteran

    240
    Mar 19, 2011
    The OC
    yes i'm using the built in flash. i use manual mode w mainly the panny 20mm 1.7 (which should be plenty fast). i wasn't sure if there was a setting i'm missing whether it be the delay of the flash or not. i'll look into that flash diffuser. is it better to use another attachment with a flash diffuser? i'm trying to avoid any other thing that will make my camera big.
     
  5. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
    You just never know without clarifying information. Reads like an auxiliary flash to me, so I asked for more info.