E-PL1 Not Detecting Native Lenses

Discussion in 'Olympus Cameras' started by Soarne, May 13, 2012.

  1. Soarne

    Soarne New to Mu-43

    6
    Apr 3, 2012
    United States
    I used the register feature to set my focal length to 50mm, when using a Leica 50mm lens. Unfortunately, now the camera does not seem to detect when I've put a native lens back on, such as my 14mm.

    Is there something obvious that I'm missing here?
     
  2. wlewisiii

    wlewisiii Mu-43 Veteran

    241
    Dec 16, 2011
    Hayward, WI
    William Barnett-Lewis
    Where is this register feature located? I'm not seeing it on my E-PL1 & it might be useful with my Summitar.
     
  3. Soarne

    Soarne New to Mu-43

    6
    Apr 3, 2012
    United States
    From the IS screen, hit the right arrow. This takes you to the focal length adjustment menu.

    Menu > Image Stabilizer > Right Arrow (flash button) > Focal Length

    If that doesn't work for you, let me know. :)
     
  4. wlewisiii

    wlewisiii Mu-43 Veteran

    241
    Dec 16, 2011
    Hayward, WI
    William Barnett-Lewis
    Oh, yeah, I've got that set. For some reason I thought you ment something else.

    And my camera sees my only native lens, the 14-42 kit lens, just fine.

    Cruft on the contacts, perhaps?
     
  5. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    Setting the focal length for the IS system does not effect native lenses (it is ignored). The real problem is the lens and body aren't communicating, most likely due to crud on the lens contacts or the lens contacts not matching up quite right with the body.

    Try cleaning the lens contacts. Also, make sure not to depress the lens release button when screwing on the lens.

    DH