1. Reminder: Please use our affiliate links for holiday shopping!

E-P5 doesn't recognize any lens - warranty activated

Discussion in 'Olympus Cameras' started by barbosas, Dec 11, 2013.

  1. barbosas

    barbosas Mu-43 Veteran

    283
    May 7, 2013
    Lisbon
    Hi,

    I've searched a lot before activating the warranty, I found a few topics on this but nothing conclusive.

    Basically the camera stopped recognizing native lens (tested with a 17/1.8 and 45/1.8), the locking pin works smoothly, the contacts are clean, the lens locks correctly but the screen stays black with the aperture not being indicated on screen.

    The light meter works correctly, although the aperture is not displayed, in A mode the shutter speed is calculated correctly.

    Tried everything I think off, left the camera off without batteries for 24h, did an hard reset through a hidden menu (Google for a topic on this on flickr) nothing worked.

    Opened this as a reference for others and will update with more details as soon as I got more info from warranty.

    Cheers
     
    • Like Like x 1
  2. HarryS

    HarryS Mu-43 Top Veteran

    918
    Jun 23, 2012
    Midwest, USA
    With no lens at all, the screen shows light coming in?
     
  3. barbosas

    barbosas Mu-43 Veteran

    283
    May 7, 2013
    Lisbon
    No, with the lens locked in the screen remains black as if no lens is locked to the camera, but the light meter works correctly.
     
  4. barbosas

    barbosas Mu-43 Veteran

    283
    May 7, 2013
    Lisbon
    Just to make a conclusion out of this.

    The Olympus support was super fast, filed the claim on the 11th, courier picked the camera on the 12th, and on the 17th the camera arrived at my home, repaired.

    It appears that there was indeed a malfunction, the repair papers indicate that the camera was repaired, verified and cleaned although no details are specified.

    Unfortunately since no details are given I cannot help in a DYI solution for this problem (assuming it was something simple), my advice is if your camera as this symptoms and it's under warranty just send it to Olympus, if it's not under warranty, well that's up to you :)

    Another detail, my camera has less then 2 months and it was bought new from an Hong Kong dealer, that was no problem for Olympus, they still honored the warranty in EU, WW warranty is a very big advantage for Olympus IMHO.
     
    • Like Like x 2
  5. bigal1000

    bigal1000 Mu-43 Veteran

    337
    Sep 10, 2010
    New Hampshire
    It would have been nice to know what was wrong with it...
     
  6. barbosas

    barbosas Mu-43 Veteran

    283
    May 7, 2013
    Lisbon
    Unfortunately the technical guy gave me no details on the papers they sent :(