1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

E-P3 Blank Screen with 17mm lens.

Discussion in 'Olympus Cameras' started by Stevo, Aug 17, 2011.

  1. Stevo

    Stevo Mu-43 Rookie

    18
    Jul 8, 2011
    Hi everyone,

    I was delighted to finally get my E-P3 today with the 17mm kit! The first thing I did was play with an adapted OM 50mm 1.8 lens, which worked perfectly. When I attached the 17mm lens all I got was a blank screen, the menus and iso/shutter speed metering are working but nothing was showing up on screen (lens cap off) I hope its a beginner mistake or something simple that I've done that would have caused this. Any help is welcome thanks!

    -Stevo
     
  2. MikeB

    MikeB Mu-43 Regular

    125
    Jun 10, 2010
    Atlanta, GA
    Stevo, I had a similar sounding problem when I had failed to rotate a lens all the way to the locked position, and my screen was blank when I turned the camera on. Try removing and then re-installing the lens, making sure you twist it all the way to lock.
     
  3. Stevo

    Stevo Mu-43 Rookie

    18
    Jul 8, 2011
    Hey Mike thanks for the response! I've managed to twist the lens on and off a couple times and it finally worked! I'm guessing it could be the factory fresh coating on the lens contact points that wore off? Weird indeed.
     
  4. starlabs

    starlabs Mu-43 Top Veteran

    856
    Sep 30, 2010
    Los Angeles
    Try cleaning the contacts. Hopefully that'll prevent the issue from occurring again.

    Glad that you got it working though!
     
  5. Stevo

    Stevo Mu-43 Rookie

    18
    Jul 8, 2011
    thanks! Yeah I think it was a contact issue, just needed to be broken in :smile:
     
  6. thearne3

    thearne3 Mu-43 Top Veteran

    807
    Jan 28, 2010
    Redding, CT USA
    I sometimes still have that issue - regardless of lens. Reseating the lens clears it up. I've cleaned the contacts. Will keep an eye on it...
     
  7. RobWatson

    RobWatson Mu-43 Hall of Famer

    I don't know about dirty contacts but when the lens isn't all the way twisted on such that the locking pin does not fully extend then the result is as described.