1. Reminder: Please use our affiliate links for holiday shopping!

E-P2 "USB" port [SOLVED]

Discussion in 'Olympus Cameras' started by pdh, May 20, 2010.

  1. pdh

    pdh Mu-43 Top Veteran

    598
    May 6, 2010
    A standard mini-USB plug will not fit what looks very like a standard mini-USB socket on the E-P2.
    The supplied cable is OK of course.

    Is this correct? Are Olympus using a proprietary socket on the E-P2 ?

    (this is causing me a protracted saga on eBay with a seller who refuses to believe their RM_UC1 clone won;t fit my camera!)
     
  2. keehotee

    keehotee Mu-43 Rookie

    16
    Mar 22, 2010
    Bristol, UK
    The RM-UC1 clone I bought on ebay for my E-PL1 (before I found out it would never work) has the correct end.....are you sure you're not getting mixed up?AFAIK the usb socket on the E-P1, 2, and E-PL1 are all the same size and shape.... which definitely isn't standard mini usb.

    p.s. All of which means - if you're in the UK you can have mine for the cost of postage.... ;)
     
  3. pdh

    pdh Mu-43 Top Veteran

    598
    May 6, 2010
    why would i want something that "would never work"?
    And what do you think I am getting "mixed up" by ?
     
  4. Streetshooter

    Streetshooter Administrator Emeritus

    Dec 15, 2009
    Phila, Pa USA
  5. pdh

    pdh Mu-43 Top Veteran

    598
    May 6, 2010
    Straight answers are fine: I'm not making any assertions, I just want to know!

    If my assumption that I'm looking at a USB port, or that you can use a remote release with the E-P2 is wrong, let me know!
     
  6. BBW

    BBW Super Moderator Emeritus

    I wish I could be the answer giver but I'm not the most tech savvy. One end of that cable is very a very "normal" looking USB but that other end is very slim. Here's Olympus's technical page, in the off chance you haven't seen it. I'd think the manual would address this, too, wouldn't it? E-P2 Specs
     
  7. squeegee

    squeegee Mu-43 Veteran

    403
    Jan 26, 2010
    for my e-p1 (which is suppose to be identical to the e-p2)

    1) the plug is NOT a USB plug, it's an olympus proprietary plug.

    2) RM-UC1 cable and clones (as long as they're made properly) will work on the e-p1 and e-p2 (but not the e-pl1). You can check the manual to see that it clearly states the RM-UC1 is a supported accessory. If the "clone" is a real clone, then it will work.

    P.S. I have an e-p1 and I have an ebay RM-UC1 clone cable and it works fine.

    https://www.mu-43.com/f67/remote-release-e-p2-1808/

    https://www.mu-43.com/f67/rm-uc1-glitch-2657/

    https://www.mu-43.com/f67/building-your-own-shutter-release-cable-e-p1-2749/
     
    • Like Like x 1
  8. pdh

    pdh Mu-43 Top Veteran

    598
    May 6, 2010
    Top notch, thanks BBW and squeegee

    I think I probably managed to pick the only eBay clone that won't fit (or maybe they just sent me the wrong one)
     
    • Like Like x 1
  9. BBW

    BBW Super Moderator Emeritus

    Glad to have been of help and thank you Squeegee!!

    Best wishes, pdh, on your eBay issues. I know they can be annoying but I hope this one won't be too expensive.
     
  10. keehotee

    keehotee Mu-43 Rookie

    16
    Mar 22, 2010
    Bristol, UK
    The remote won't work with the E-PL1!!!
    And your assumption that the E-P2 has a mini usb connection.

    I don't know - you try to help somebody out and even offer a free remote, and just get shot down. Why bother !
     
  11. cosinaphile

    cosinaphile Mu-43 All-Pro

    Dec 26, 2009
    new york city
    proprietary fitting , yes very annoying
     
  12. Streetshooter

    Streetshooter Administrator Emeritus

    Dec 15, 2009
    Phila, Pa USA
    Why bother?
    Because sometimes what you write helps someone see the light.
    It may not be the OP but others read your words.
    That's why......

    Go in peace, both of ya.....
     
  13. kevinparis

    kevinparis Cantankerous Scotsman

    Feb 12, 2010
    Gent, Belgium
    the 'usb' connector on the Olympuses are proprietry - they carry USB signals and composite video and perhaps audio - to allow you to play back your photos on a TV.... like anybody ever does that

    K
     
    • Like Like x 1
  14. PeterB666

    PeterB666 Mu-43 Top Veteran

    780
    Jan 14, 2010
    Tura Beach, Australia
    Peter
    The connector is nothing like a standard mini-USB port. It is a multi-function port that takes the Olympus supplied USB cable to connect to another USB port, or the Olympus supplied video connector to connect to an AV device like a TV.

    I have a remote RM_UC1 compatible clone for my E-P1 and it works fine.

    I have heard reports the the E-PL1 is not compatible with any remote but cannot verify this. Sort of makes the 'bulb' function on that camera useless.
     
  15. BartonFlyer

    BartonFlyer Mu-43 Regular

    105
    Jan 21, 2010
    Bolton, UK
    Hi E-P2 users!!

    Resurrecting this thread with a plea for help

    I have connected my E-P2 to my Windows XP laptop via the USB cable - on connection the camera wakes up and shows a menu

    USB

    STORAGE
    MTP
    PRINT
    EXIT

    If I choose any option (except EXIT) - the camera then just displays "ONE MOMENT" and sits forever doing nothing. On the laptop there is no activity - I'd expect that the file system would show up in Explorer but nothing happens.

    Anyone got any ideas?

    Thanks
    Ian
     
  16. WasOM3user

    WasOM3user Mu-43 Veteran

    458
    Oct 20, 2012
    Lancashire, UK
    Paul
    XP likes to have the USB drivers installed before you plug in the camera (or any USB device). Sometimes it will just sit there without warning you it needs a driver.

    With the camera plugged in Have a look in the device manager to see if you have an icon with a yellow warning on it - if so try right clicking and see if you can get it to look for a driver online.

    If you have the CD try looking for the driver to install (but you may have to install Olympus' software to get it on)
     
  17. BartonFlyer

    BartonFlyer Mu-43 Regular

    105
    Jan 21, 2010
    Bolton, UK
    Thanks for the reply - in fact I solved it (shamefacedly) by being much more forceful with the camera end of the connecting cable - seems you need to push it on then push some more!!
    Always the simple things in the end ......
     
  18. gohunter

    gohunter New to Mu-43

    6
    Jan 6, 2014
    Wirral, UK
    Gordon
    Ian,

    You solved my problem with my E-P2. I too was not forceful enough and thought that the camera that I'd picked up off eBay a few months ago was faulty. However, pushing the connector hard allowed me to update to V1.3 firmware.

    Cheers,

    Gordon