1. Reminder: Please use our affiliate links for holiday shopping!

E-P1 Stopped working with native lenses

Discussion in 'Olympus Cameras' started by Tecpatl4, Dec 23, 2011.

  1. Tecpatl4

    Tecpatl4 Mu-43 Veteran

    292
    Oct 16, 2010
    Midwest
    I used my camera the other day with an OM lens with adapter. Today I wanted to take some pictures at a birthday party with the Panny 20mm. But with either the 20mm or the 14-42 mounted it seems that the sensor turns off. The LCD shows the icons but no image otherwise. It works find with manual focus lenses.

    Also with a native lens mounted, the shutter, autofocus etc. doesn't work. I can still get to the menus but that's about it.
    I've tried removed the battery, and the in camera reset.

    Anybody have any suggestions for rescuing this thing? Other than an upgrade to E-P3 I mean.
     
  2. fdifulco

    fdifulco Mu-43 Veteran

    251
    Nov 28, 2011
    New Orleans, Louisiana
    Frank
    a reset

    did you try the reset option in the camera with the lens off or take the battery out for about 5 min?

    i had this problem with a mmf-2 adapter on my E-P3 when i tried it with one of my 4/3 lens. it would not recognize any lens. i took the battery out for 5 minutes and selected the reset to factory default with out a lens mounted. i then did a normal power off and mounted a lens. i sent that mmf2 back - it locked up the camera each time i tried.
     
  3. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    You have two other options as well... upgrade to the E-PL2 or upgrade to the E-PL3. ;)

    Maybe try cleaning your contacts? Since it's working with manual lenses, whatever's wrong must have something to do with when the lens contacts are used.
     
  4. KVG

    KVG Banned User

    May 10, 2011
    yyc(Calgary, AB)
    Kelly Gibbons
    Just get a Panasonic, they don't have these problems:tongue:


    But really they don't:biggrin:
     
  5. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    It's probably a communication issue. Adapted lenses don't touch the contact pins on the lens mount, but native lenses do. Try cleaning the contacts on the body and on the lens itself.

    DH
     
  6. Tecpatl4

    Tecpatl4 Mu-43 Veteran

    292
    Oct 16, 2010
    Midwest
    After playing around with it for a little while and a little research I got it working again. The issue is the lens release button. When you press that, it turns the sensor off. The switch was suck, after wiggling that it started working again.
     
  7. b-bernd

    b-bernd New to Mu-43

    8
    Dec 27, 2011
    Germany
    I have the same problem with my E-PL1. I used the Novoflex-adapter with m42-lenses, and when I changed to the kit lens the screen showed no picture. After wiggling and trying several times one day and the following day the camera startet to work again with the 17mm-pancake. Now I haven't changed the lens since then.
    Best,Bernd