E-M5 Main Dial behaviour

Discussion in 'Olympus Cameras' started by RedSnapper, Apr 27, 2012.

  1. RedSnapper

    RedSnapper Mu-43 Rookie

    Aug 28, 2010

    I've just exchanged my E-P3 for an E-M5. I'm playing with the settings, and I've found that my main dial doesn't seem to work (or is it something I've done?).

    To cut a medium length story short, in aperture priority, whatever the aperture is, rotating the dial one click adjusts it by 1 unit (1/3 stop?) up or down. A second click reverts it to the previous value - like a toggle. I can only get 2 different apertures.

    I'm using the 12-50, which worked fine on the E-P3.

    I've reset the settings (Full), but it hasn't helped.

    (I get the equivalent effect in shutter priority.)

    Any ideas?

  2. ill_dawg

    ill_dawg Mu-43 Veteran

    Aug 26, 2010
    Sounds like the dial might be bad. This doesn't sound like normal behavior, and I've had bad volume dials do the same thing on me. Someone else might be able to chime in with more advice, but I'd be thinking about the warranty.

    Before that, though, have you tried the other dial to make sure they're not switched? Have you tried using the misbehaving dial in non-shooting modes, like playback, to see if it still misbehaves? Have you tried turning it more than one click quickly? If that last one works, it might be a bad connection.

    Sorry I can't be more help, as I still don't have mine in my hands, but hopefully someone else will pick up the ball.
  3. Lawrence A.

    Lawrence A. Mu-43 All-Pro

    Mar 14, 2012
    New Mexico
    Real Name:
    That's not how my dial is working. Click once, a third; twice 2/3, etc. All my digital E system and m4/3 lenses can go through the whole f stop series.

    I know of no setting that would induce that kind of behavior, and no reason, really, why there would be such a setting. I'd email Olympus. They are closed for the weekend, I imagine, but I've always had a less than one working day response from them.
  4. jgregs

    jgregs Mu-43 Regular

    Nov 21, 2010
    Southern Ontario
    I know you've reset all settings, but how about just switching dial functions and/or reverting back to them, see if the problem continues when you use a different dial for the same function?

    thought it might be EV step settings but can't be that =/