E-M10III - weird evf black-out on half press

S-Osolin

Mu-43 Regular
Joined
Feb 20, 2019
Messages
90
I'm battling a weird problem lately. Picture in evf will occasionally completely disappear when I engage auto focus by half pressing shutter. Camera and lens will focus, but as soon as af motor on the lens stops working, evf will black out. Picture will come back as soon as I release or engage shutter. It's a bit random, it does not happen all the time, if I half press shutter the next time, then, almost certainly, there will be no black out. I don't think ibis is a factor. I had blackouts already when I turned it off. I also had no problems when I was in MF mode. I believe it also does not happen when I'm not using EVF, but I've not tested this out extensively, yet.
Weirdly, this only happens on my Olympus lenses. But it happens on all my Olympus lenses. 25mm, 75-300mm, 60mm, kit 40-150mm. It never happened on my Panasonic or Sigma lenses. And never on my MF lenses.

It's not a huge problem, half the time It does not matter at all, since I immediately engage shutter, but in macro, where I like to engage af, then leave it half pressed until I fine tune focus, it is a problem. It still is a nuisance that creeps up from time to time, and I'm wondering if anyone ever encountered anything like that before.
 
Last edited:

Carbonman

Mu-43 Hall of Famer
Joined
Jul 10, 2014
Messages
2,610
Location
Vancouver BC
Real Name
Graham
I ran into this problem with my E-M1 II and the 7-14mm f2.8 occasionally. In my case it boiled down to improper camera handling - I was accidentally pressing the lens mount lock button part way down and it was shutting the EVF down as long as my finger or hand was pressing against it. Drove me crazy until I figured it out.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom