E-M1 died. No power. Help?

Discussion in 'Olympus Cameras' started by RakSiam, Apr 9, 2016.

  1. RakSiam

    RakSiam Mu-43 Regular

    Oct 11, 2013
    I've had my E-M1 since it first came out. It's been a total joy and the best camera I have ever used. But now it seems to have died. Just now it powered on fine and when I zoomed in with my 40-150 PRO everything went black. Tried cycling the power switch. Nothing. Changed the battery. Nothing. Changed the lens. Nothing. The power meter had read full last night when I checked. Tried battery #3. Still nothing.

    So I am guessing this is a catastrophic failure. Could it be the power switch? I am charging the first battery at the moment to see if maybe it was just a matter of the batteries all being dead, but that seems highly unlikely. Anyone else experience anything like this?
  2. Growltiger

    Growltiger Mu-43 Top Veteran

    Mar 26, 2014
    Take the lens off and take the SD card out and try again.
  3. Harvey Melvin Richards

    Harvey Melvin Richards Photo Posting Junkie

    Feb 15, 2014
    Southwest Utah
    My newest E-M10 has failed twice in a similar manner. It came on briefly, but I couldn't select anything, then it would go black. Both times it went in for repair, but I don't know what was fixed.
  4. RakSiam

    RakSiam Mu-43 Regular

    Oct 11, 2013
    I just noticed that the shutter is closed. Which it shouldn't be. I did try taking everything out and replacing.
  5. Klorenzo

    Klorenzo Mu-43 All-Pro

    Mar 10, 2014
    On E-M10 I had about three random black outs in a couple of months with the shutter stuck closed (always when using flash). Turning off/on the camera solved the problem. On the fourth time it remained stuck, dead and it was fixed with a shutter replacement.