DNG conversion problem

Discussion in 'Panasonic Cameras' started by benjie, May 20, 2010.

  1. benjie

    benjie Mu-43 Regular

    63
    May 17, 2010
    London
    Hi- I've been trying to convert RAW files from my G1 to DNG, so far without success. I use Photoshop CS2 and ACR. Any ideas? Which version should I be using? Thanks
     
  2. Streetshooter

    Streetshooter Administrator Emeritus Subscribing Member Charter Member

    Dec 15, 2009
    Phila, Pa USA
    You need to download the new camera raw. But, it won't work with CS2. So, download it and use the stand alone DNG converter.
    Convert on your desktop and import to your program. CS2 may not recognize the file and then you have to feed Adobe for the upgrade...
     
  3. Jonas B

    Jonas B Guest

    91
    Apr 23, 2010
    Gothenburg, Sweden
    I don't recall the exact details about CS2 and the G1 DNG files. But this is what I would try (I have now updated my Photoshop and uninstalled the old version so I can't try it it, again):

    Download the Adobe DNG converter Streetshooter mentioned. Put a G1 raw file taken with a Panasonic lens and one taken with a manual adapted lens in a directory to test it. Start the DNG converter and check the settings. What you need is to find what output version of the DNGs that can be handled by Photoshop and Bridge CS2. Start with DNG v2.4, go to v4.1 and so on and see what works for you.

    You'll find that the older versions of the DNG format make for huge DNG files if you have used a Panasonic lens when shooting. That has to do with the "problem" introduced by Panasonic by adding the lens correction data to the raw files and it took some time for Adobe to include these data and still being able to compress the DNG file (or keep the raw format technically speaking). 45MB files... not funny. The DNGs from adapted manual lenses will be around 12MB as expected.

    Let us know if you succeed or if you need more ideas, OK?

    Jonas
     
  4. benjie

    benjie Mu-43 Regular

    63
    May 17, 2010
    London
    Thanks to both for your help. I changed the settings on the converter to 2.1 and that did the trick :smile:
     
  5. Jonas B

    Jonas B Guest

    91
    Apr 23, 2010
    Gothenburg, Sweden
    2.1 even. How fast one forgets! It's good you got it solved.
     
  6. benjie

    benjie Mu-43 Regular

    63
    May 17, 2010
    London
    Thanks. But my mistake- it was 2.4!