Canon 300mm L f4 lens issue

Discussion in 'Adapted Lenses' started by Gary Ramey, Aug 19, 2013.

  1. Gary Ramey

    Gary Ramey Mu-43 Veteran

    240
    Dec 27, 2012
    Aurora Colorado
    When I first got this lens I had no issue at all and it was tack sharp at all f stops. Lately, and after a trip in a suitcase, the lens doesn't want to focus to infinity on my OMD. Is there the possibility the lens mechanics are bad? It still feels smooth with no issues. I'm a little bummed because I was having a great time with this lens. Any suggestions?
     
  2. meyerweb

    meyerweb Mu-43 Hall of Famer Subscribing Member

    Sep 5, 2011
    Do you have access to a Canon camera to test the lens on?
     
  3. MitchHamilton

    MitchHamilton Mu-43 Regular

    42
    Feb 16, 2010
    Banff, Alberta, Canada
    Is it the FD version or the EF version? Check that you don't have build up on the adapter, even a millimeter of variance on the adapter can throw infinity focus off.
     
  4. Gary Ramey

    Gary Ramey Mu-43 Veteran

    240
    Dec 27, 2012
    Aurora Colorado
    Thanks, it's Manuel focus and aperture. What happened is there is a little screw that goes through a plastic standoff that moves the focus when you rotate the barrel. That screw was stripped. The only way to replace it was a complete disassembly...which I attempted. I fixed the focus but was unable to get the aperture ring in place and working so I simple removed it and shoot the lens wide open.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.