Bought a faulty 9-18 m.zuiko

Discussion in 'Native Lenses' started by flash, Dec 15, 2010.

  1. flash

    flash Mu-43 Hall of Famer

    Apr 29, 2010
    1 hour from Sydney Australia.
    Gordon
    Just rotten luck I suppose. It's "supposed" to be 1 month old, and it looks in good condition but the AF is faulty. It just racks back and forward and then gives up. I've tried it on three Pen bodies. All my other lenses work just fine. manual focus is OK but that's not going to help me when I use it in a housing.

    So my options are to return it or have it fixed (under warranty?).

    But before I send it off, I'd like to reload the firmware if that is possible. It's on 1.0 and I don't think there's an upgrade. Does anyone know if it's possible to reload the firmware without taking it to Olympus?

    Gordon
     
  2. wyip

    wyip Mu-43 Regular

    77
    Nov 17, 2010
    San Francisco, CA
    It's worth a shot, but the Olympus updater software probably will just say there are no updates available for the lens and the 1.0 firmware does not appear to be downloadable.
     
  3. Streetshooter

    Streetshooter Administrator Emeritus

    Dec 15, 2009
    Phila, Pa USA
    Have you tried cleaning the contacts on the rear flange? I'm sure you did that but just in case.....
     
  4. flash

    flash Mu-43 Hall of Famer

    Apr 29, 2010
    1 hour from Sydney Australia.
    Gordon
    Thanks. Have done that. I have sent an email to Olympus to see if it's possible to reload firmware and bypass the updater. We'll see...

    Gordon