Blank screen with Pro Lens

Discussion in 'Olympus Cameras' started by Johnny Tron, Dec 13, 2015.

  1. Johnny Tron

    Johnny Tron New to Mu-43

    2
    Dec 13, 2015
    I just ran the firmware update (4.0) on my em1 as well as for my 12-40 pro lens and now I am getting a blank screen and no option to fire the shutter although all menu buttons work. I put on a different lens and everything was normal, went back to pro lens and same thing. removed the battery and still the same thing. I am REALLY hoping this is an easy fix as I leave for mexico in three days. anybody have any recommendations?
     
  2. walter_j

    walter_j Mu-43 Veteran

    365
    Sep 10, 2013
    Hagwilget, B.C., Canada
    Walter
    the only time I've had such a problem is when the lens isn't quite locked on. I had to make sure I rotated it enough
     
  3. mcasan

    mcasan Mu-43 All-Pro

    Feb 26, 2014
    Atlanta
    Maybe not the best forum for the question as this is one for news and rumors about M43 equipment. You might have better luck with the Olympus camera forum.
     
  4. barry13

    barry13 Super Moderator; Photon Wrangler

    Mar 7, 2014
    Southern California
    Barry
    Does the updated still see the lens?

    It's possible the lens' firmware wasn't written correctly, in which case you'd usually have to send it in for repair.

    Barry

    P.S. I moved this to the Olympus Cameras forum.
     
  5. Johnny Tron

    Johnny Tron New to Mu-43

    2
    Dec 13, 2015
    Thanks for the reply's so far everyone, and apologies for posting the wrong forum! I tried checking the firmware, but since the body isn't reading the lens, it didn't show up on the computer. it seems to connect and "click" normal, but perhaps the spring pin isn't being released once it connects. I'm going to take it to the shop this morning and will update after.
     
  6. PakkyT

    PakkyT Mu-43 Top Veteran

    767
    Jun 20, 2015
    New England
    Some lenses will allow you to twist them on a bit too far. Meaning if you hold in the body button while putting the lens on, if you go ever so slightly past where it should stop, the button will remain depressed. You can (without holding the button) turn the lens back the other way and see if it locks in better. In general, never push or hold the button will putting lenses on. Just turn them until they click without the button.

    This probably isn't your problem unfortunately, but thought I would mention it if you want to check it to be double sure it isn't that.