1. Reminder: Please use our affiliate links for holiday shopping!

Blank screen, only display data - no image

Discussion in 'Olympus Cameras' started by roll82, Jul 19, 2013.

  1. roll82

    roll82 New to Mu-43

    5
    Jul 19, 2013
    Hi, im having a error with my lens or the connector to it or the camera (hope not).
    When i turn on the camera i can only see a blank / black screen and no image. I can see all the data on the display but no image coming through the lens. For weeks i have been having the same issue but after turning it on and off a couple of times it got better, now its black. I can see the camera display with the settings on it but no image. Have tried to clean the lens and around themount with the blower but no luck.

    Also upgraded to firmware 1,7.

    anyone had the same issue? Have the 12-50mm kit lens. Thanks.
     
  2. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    Make sure the lens is fully attached by turning the lens either direction WITHOUT pressing the lens release button.

    When attaching a lens don't press the lens release button.

    When using the camera don't press the lens release button.
     
  3. ccplady

    ccplady Mu-43 Regular

    49
    May 15, 2012
    Orlando. FL
    Amy
    Press and release the lens release button a couple of times. Every now and then the little metal "prong" on the camera's lens mount ring (the prong closest to the release button) will get stuck in the retracted position. When in that position, the camera doesn't recognize the lens is attached.

    Happens on my E-P5 every now and then.
     
  4. ccplady

    ccplady Mu-43 Regular

    49
    May 15, 2012
    Orlando. FL
    Amy
    It totally freaked me out the first time it happened, but I figured it out in a few minutes, and all was well in the world again!
     
  5. DeeJayK

    DeeJayK Mu-43 Hall of Famer

    Feb 8, 2011
    Pacific Northwest, USA
    Keith
    This happens to me fairly regularly...10 times out of 10 it's because I've failed to remove the lens cap. :biggrin:

    sent with my phone...please excuse the typos
     
  6. roll82

    roll82 New to Mu-43

    5
    Jul 19, 2013
    Thanks guys for all your ideas, have tried everything above... no luck :(

    Here a quick video i recorded to see what my problem is. Also realized that when i turn the zoom on the lens nothing is happening. I can see (also in the video) that the apperture number is moving when i move around but stil a black image (and yes the lens cap if of :) )

    Olympus OMD EM-5 not recognizing lens - blank image - YouTube

    THaNKS FOR ALL YOUR HELP
     
  7. ccplady

    ccplady Mu-43 Regular

    49
    May 15, 2012
    Orlando. FL
    Amy
    I'm really surprised you don't have a stuck pin. When you twist your lenses on the camera, do you hear the final, quiet click? Does your lens twist off without pressing the release button? I know my experience is with the E-P5 and not the OM-D, but I owned the OM-D before and they are virtually identical.

    image42.
     
  8. roll82

    roll82 New to Mu-43

    5
    Jul 19, 2013
    Thanks...yep..i can hear the final click and the lens is fully in. Just checked the pin and it looks ok to me.
     
  9. ccplady

    ccplady Mu-43 Regular

    49
    May 15, 2012
    Orlando. FL
    Amy
    RATS! I'm really sorry it didn't help.
     
  10. yourguitarhero

    yourguitarhero Mu-43 Regular

    78
    Jul 29, 2011
    Take the lens cap off
     
  11. Henk

    Henk Mu-43 Regular

    194
    Aug 18, 2010
    the Netherlands
    If you'd read the OP's posts you would have seen that he has taken the lens cap off.
     
  12. Henk

    Henk Mu-43 Regular

    194
    Aug 18, 2010
    the Netherlands
    That's the exposure compensation value you see changing when you move the camera around. The aperture value should be where the -.- mark is and this is an indication of bad communication between lens and camera.

    You could try to clean the contacts of camera and lens carefully, maybe it helps. Do you have another lens to try? In the shop where you bought it?
     
  13. roll82

    roll82 New to Mu-43

    5
    Jul 19, 2013
    Thanks guys for all your help.. Have tried to clean very carefully the pins and connectors but it was perfectly clean. Might go to the shop today to see what they think. Was hoping that anyone had a similar experience here. ...Well..this might be a good excuse to look at the Leica 25mm 1.4f :)

    photo_1_1.

    photo_2_1.
     
  14. entropicremnants

    entropicremnants Mu-43 All-Pro

    Jul 16, 2012
    John Griggs
    I have an E-P1 that does that every time it's been turned off for 20 minutes or more. On that cam, you just turn it off and right back on and you get an image.

    I have no idea what that's all about, but it always works. I bought it that way and my 10 year old grandson is using it at the moment and he's fine with it. An old micro four thirds cam beats the heck out of his old P&S camera, lol.
     
  15. Henk

    Henk Mu-43 Regular

    194
    Aug 18, 2010
    the Netherlands
    It seems like you have a faulty lens, hope you can get it exchanged in the shop. Good luck!
     
  16. M4/3

    M4/3 Mu-43 Top Veteran

    713
    Sep 24, 2011
    Has happened to me more than once too - E-M5 is the first fragile Olympus camera I've owned. Previous models going back to 2001 were rugged.
     
  17. Neftun

    Neftun Mu-43 Veteran

    408
    Jul 15, 2012
    Norway
    Patrick Kristiansen
    Something similar has happened to me as well, but only with that lens. Jerking the zoomring back and forth a couple of times solved the issue though..
     
  18. Clint

    Clint Mu-43 All-Pro

    Apr 22, 2013
    San Diego area, CA
    Clint
    I had that happen about two weeks ago while on a job, removed and replaced the lens, changed the lens to another, removed the HLD-6 and camera battery and then reinstalled, still no luck. I removed the HLD-6 and batteries, put them in the case and changed ot another camera.

    When I got home I charged both batteries, the next day reasembled everything, and reset the camera, the camera was back to normal.
     
  19. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
    Is this a new problem or has it happened ever since it came out the box?
    I had the same thing happen with an amazon warehouse pz 45-175mm. Its probably a bad lens. Ive heard this happening after a botched lens firmware update as well. Best thing to do is to get another lens and see if that works.
     
  20. roll82

    roll82 New to Mu-43

    5
    Jul 19, 2013
    Thanks to all your support guys. Have tried everything with no luck. Lucky the camera still has warranty and an Olympus repair shop is just up the road. Have also ordered the Leica 25mm f1.4 today as an bonus for all the stress ;)