9-18mm lens error

Discussion in 'Olympus Cameras' started by MattNQ, Aug 3, 2012.

  1. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    Hello,
    My 9-18mm is well over a year old now, but has just started displaying an error on my EPL1.
    Works fine at 9mm, but if you zoom to 18mm , you get the "please check the status of a lens" error & you have to power down the camera.
    My wife though she might have bumped it on something at a recent athletics carnival while shooting video with it, and it was a wet weekend, so I am not sure if the bump. or a bit of stray moisture got in the wrong place. It still works perfectly well at 9mm though:confused:
    The only other similar thread I found here the lens was new and replaced under warranty, so no clue given as to what the actual fault might have been.
    Any ideas?
     
  2. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    I would start by examining and cleaning the contacts on the lens. The contacts can be cleaned with a clean cotton cloth and/or regular printer paper.
     
    • Like Like x 1
  3. romzL

    romzL Mu-43 Regular

    109
    May 20, 2012
    romz
    it could be the flex cable inside. normal issue with zoom lenses
     
    • Like Like x 1
  4. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    Had a play with this.
    Cleaned the contacts. No joy.
    Opened it up - the flex cable seems intact - it is quite creased where it obviously folds when the lens collapes back in - does that wear over time?

    It gives the error when auto - focusing, but only after 14mm. 9-14 is fine.
     
  5. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    Fex cables do break over time, eseciallt those in laptop lids. Even the set in my car's trunk lid broke, and they are a much thicker gauge (to carry the current for the tail lights) than those in the camera lens.
     
    • Like Like x 1
  6. StefanKruse

    StefanKruse Mu-43 Veteran

    428
    Jan 28, 2015
    Denmark
    Stefan
    Hi,

    I have just found that my lens has the exact same error. It is fine between 9-14mm but sooming past that prompts the error message. If it indeed is the flex cable (as suggested above and on other forums) how big an operation are we talking about? I bought my lens second hand thus no warrenty?
     
  7. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    I ended up sending it off to the Olympus service centre. I'd have to check the paperwork but cost me about mid $200's I think. They did return it with the part they replaced in the bag - part of the zoom mechanism. If I get time I'll see if I can find the paperwork.
     
    • Appreciate Appreciate x 1
  8. StefanKruse

    StefanKruse Mu-43 Veteran

    428
    Jan 28, 2015
    Denmark
    Stefan
    Thanks, thats a pricey operation.

    What are the pros and cons of sending it to olympus service center vs your local camera dealer?
     
  9. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    My local camera dealer here won't even sensor clean Nikon's (only Canons) let alone repair Oly gear so I didn't have much choice[emoji2].
     
  10. StefanKruse

    StefanKruse Mu-43 Veteran

    428
    Jan 28, 2015
    Denmark
    Stefan
    Thanks, I will try out my local dealer and see what happens
     
    • Like Like x 1
  11. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    Found the pieces they returned.
    You can see one end is chewed out.


    9fcd28c212ccbe4b37ec7d6c69c50fcf.
     
  12. Halaking

    Halaking Mu-43 Top Veteran

    673
    Dec 17, 2012
    Los Angeles
    Morris
    What did you do with that lens :whistling:
     
  13. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    He he...I did get it fixed. And it went back for repair a while later. Different problem. It is a great little lens, but not very robust [emoji2].
     
    • Agree Agree x 1
  14. StefanKruse

    StefanKruse Mu-43 Veteran

    428
    Jan 28, 2015
    Denmark
    Stefan
    Are these pictures showing the result of the 9-14mm zoom fix? Do you know what caused the problem in the first place i.e. what caused the flex cable to break?
     
  15. MattNQ

    MattNQ Mu-43 Regular

    83
    Jul 31, 2012
    These parts returned loose with the repaired lens. I have misplaced the paperwork, but from memory they didn't elaborate on what may have caused it.