1. Reminder: Please use our affiliate links to get to your favorite stores for holiday shopping!

75mm Finally came! ...and I have to send it in

Discussion in 'Native Lenses' started by mister_roboto, Sep 5, 2012.

  1. mister_roboto

    mister_roboto Mu-43 Top Veteran

    637
    Jun 14, 2011
    Seattle, WA, USA
    Dennis
    I had preordered on May 24th from B&H, but they didn't have enough units in the first batch, but the second batch they got a week ago- had my lens in it. I had only one last trip this summer... and it was delivered 1 hour before my flight left :frown: however "whatever"- at least I got it! :cloud-9-039:

    Came back from vacation- picked it up at work, stealthy sneaking in with my shorts and unshaven face to get my lens. Brought it home- and the first thing I wanted to do was look through that big wonderful front element that's so uncommon in modern digital lenses, only to see....

    7938781242_c6315996f2_b.

    There's a bit of black debris inside the lens on an element. I did the "can shake" with the lens- it's not budging. It's only viewable at f5.6 as an out of focus mostly transparent blob, but by f10 it's pretty clear, and after that it's obviously there.

    So I'm going to contact Olympus USA and get it fixed (probably swapped), well- at least it's not like I had anymore trips left to take it on this summer :crying:
     
  2. Aegon

    Aegon Mu-43 Veteran

    334
    Nov 3, 2011
    Portland, OR
    • Like Like x 1
  3. ptolemyx

    ptolemyx Mu-43 Veteran

    290
    Jun 19, 2012
    Vancouver, BC
    Ben
    Amazing. Don't they do this most basic check in QA before shipping them out?
     
    • Like Like x 1
  4. mister_roboto

    mister_roboto Mu-43 Top Veteran

    637
    Jun 14, 2011
    Seattle, WA, USA
    Dennis
    Heheheh- yeah I immediately thought about that article, and very quickly determined I'm not Roger Cicala and I can see it becoming a "Lucy at the chocolate conveyor belt" scenario.

    The thing is- *most* of the time it won't bother me much. But it's more about he principal of it being a High Grade lens with the quality that goes with that title, and the price point that makes me want to send it. I am also kind of wondering how it was missed from a quality check too- since it (my guess only) should be easy to find at the end of it's assembly.
     
  5. krugorg

    krugorg Mu-43 Hall of Famer

    Jul 18, 2011
    Minnesota USA
    Awww, that stinks! Hope Olympus gets that turned around quickly for ya!

    I wonder if it is something that could have shaken lose in shipping (and would not have been apparent during QA)?
     
    • Like Like x 1
  6. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
    I had something like that stuck on my 14-150, showed up around f8...looked like cigarette ash. I took my Sonicare toothbrush, wrapped the head in lens paper, and put the plastic part of the head on the lens for a few seconds. The dust fell into the abyss of the barrel, never to be seen again :D
     
    • Like Like x 2
  7. jloden

    jloden Mu-43 Hall of Famer

    May 15, 2012
    Hunterdon County, NJ
    Jay
    Ah man, that's such a bummer, especially with a brand new lens. Hope you get your lens back soon good as new!
     
  8. mister_roboto

    mister_roboto Mu-43 Top Veteran

    637
    Jun 14, 2011
    Seattle, WA, USA
    Dennis
    Following what krugor said about it possibly being knocked around during shipping- and your suggestion about the vibration from the electric toothbrush, I decided to step up from "can shake" to "palm slapping" the side of the barrel.

    I smacked the side of the lens about 5 times with the palm of my hand... to get +1 additional black piece of debris inside :dash2: It was smaller than the one that was in there already at least.

    Then I stepped it up to "rapid palm slapping" - and... it's clear and free! No more debris. :2thumbs: I guess if it ever shows up again- I know what to do.
     
    • Like Like x 1
  9. kwalsh

    kwalsh Mu-43 Top Veteran

    775
    Mar 3, 2012
    Baltimore, MD
    Aww, bummer.

    I got mine a week or so ago from ********** and first thing I did was look through the lens. Had a few more dust specs than I'm used to from a new lens, but nothing like what you've got and nothing that would have any impact on the image. Mine are tiny and are only visible with strong off-axis light.

    Best of luck getting it resolved! Let us know how your Olympus service experience goes.
     
  10. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
    Sweeeet!! Glad it worked....just needed a good ol' spankin :D
     
    • Like Like x 1
  11. RevBob

    RevBob Super Moderator

    Jun 4, 2011
    NorthWestern PA
    Bob
    Celebrate! :dance4:
     
    • Like Like x 1