45 mm lens not recgnised

Discussion in 'Native Lenses' started by jorgetalko, Feb 1, 2015.

  1. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    After uudating the firmware fo my OMD5 and epl7 cameras, the 45 mm M Zuiko is no recognised by obth cameras.
    I clean the contacts but the problem continues.
    Any idea?
    Thanks
     
  2. bg2b

    bg2b Mu-43 Regular

    53
    Dec 22, 2009
    Berkeley Heights, NJ
    Was the lens on one of the cameras when it was updating? There was a firmware update for the 45 at some point, and if you didn't apply that earlier, maybe the lens firmware was being updated too and something went wrong during that update.
     
  3. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    During updating the 45 mm not was on camera.
     
  4. xvvvz

    xvvvz Mu-43 Regular

    85
    Jul 2, 2013
    Did you check the firmware version of your lens before all of the trouble started? Did the lens have the latest 1.1 firmware? If it didn't have 1.1 before the trouble started, have you tried putting the 1.1 firmware update file on a memory card and seeing if the camera might try to install it by default and thus resurrect the lens?
     
  5. HarryS

    HarryS Mu-43 Top Veteran

    921
    Jun 23, 2012
    Midwest, USA
    The 45mm has always been one of the tightest fitting lenses. Even after 3 years, I occasionally mount mine and it does not register on my Olympus bodies. Needs an extra wiggle and a twist to make sure that the lens clikcs and has fallen into the the locked position.
     
  6. zensu

    zensu An Old Fool

    Aug 8, 2012
    Southeastern USA
    Bobby
    +1 All of my 3 Olympus and 1 Panasonic lens have been super tight since first used. This was true on my previous E-M5 and current E-P5. I really have to make sure that cameras locking pin engages the lens.
     
  7. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    How can downlowd the 1.1 to a memory card?
     
  8. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    How can downlowd the 1.1 to a memory card?
     
  9. zensu

    zensu An Old Fool

    Aug 8, 2012
    Southeastern USA
    Bobby
    You don't load the Firmware on an Olympus m43s camera, I'm not sure about Panasonic.
    Here's the link:
    http://www.olympus.co.jp/en/support/imsg/digicamera/download/software/firm/e1/#omd
    This is the Update site for Olympus and Panasonic. With Olympus just follow the instructions for upgrading Firmware. I believe you'll have to actually remove the SD card then plug your camera + lens into your computers USB port and run the Updater Program.
    I've done it with all my lenses and so far no problems. Just remember to be patient while it updates.
    Bobby
    Just read up on this and with Panasonic you DO put the file on an SD card to update Firmware.
    Here's a link to Panny Update:
    http://av.jpn.support.panasonic.com/support/global/cs/dsc/download/fts/step_l2.html
    Good luck
    Bobby
     
  10. HarryS

    HarryS Mu-43 Top Veteran

    921
    Jun 23, 2012
    Midwest, USA
    If a lens doesn't work in two cameras, and you know it's clicked into plce, then the lens probably went bad while it was sitting around. Failed electronics or something.
     
  11. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    This was the answer form Olympus suport form USA and Europe. Now the lens will go to the service lab.
     
  12. jorgetalko

    jorgetalko Mu-43 Rookie

    14
    Jun 16, 2012
    Buenos Aires
    To day i sent the lens to the local service.